Back to overview
Resolved

Production Release - Version 2607.2

Jul 22, 2026 at 10:00pm UTC  –  Jul 23, 2026 at 12:00am UTC
Affected services
EdGraph Marketing Web
EdGraph Management API
EdGraph Tenant API

Resolved
Jul 23, 2026 at 12:00am UTC

Maintenance ended

Created
Jul 22, 2026 at 10:00pm UTC

Sprint 136 - v2607.2
QA: 7/20
Prod: 7/22